RenderTexture captured from camera with post effects only shows the emission pass.

Since formatting is so painful here, here is a link on StackOverflow:

I see similar posts regarding this, but they haven’t been answered. I personally have run into this twice now in the last few months. I really hope someone out there knows how to capture from a camera using post effects. My only solutions have been completely jank, and too slow for real-time.

To answer my own question: On the PostProcessLayer component, there is a “Keep Alpha” checkbox that needs to be checked to avoid the transparency issues.

When reading the description of that check box, I got the impression that when enabled, it would essentially “enable alpha,” which is why I kept it unchecked until now. It appears to have the opposite effect, checking the “Keep Alpha” checkbox seems to make the result opaque, which is exactly what I wanted! Hooray!