Reproducible Win10 bluescreen crash when switching platform to Android, 2018.4.20f1

I build 2018 projects for VRChat, and one of my projects is reliably causing Windows 10 to bluescreen while switching platforms from Windows to Android. I have other projects that switch back and forth with no issue.

This project started out as 12 GB of assets. Then, I exported the single Scene, with dependencies, created a new project, and imported the package. This new project with similar assets is only 2.5 GB. It still gives me a bluescreen when trying to switch to Android.

I thought the issue might be a specific asset that was causing a problem on import. So I reproduced the crash three times and saved the Editor log from each:

log 1 - Initiating legacy licensing moduleLICENSE SYSTEM [2021726 20:16:18] Next lic - Pastebin.com

log 2 - Initiating legacy licensing moduleLICENSE SYSTEM [2021726 20:33:28] Next lic - Pastebin.com

log 3 - Initiating legacy licensing moduleLICENSE SYSTEM [2021726 20:52:15] Next lic - Pastebin.com

The last few entries of each log have nothing in common, so it’s not crashing while importing some specific asset.

My next thought is that I’m running out of memory. I do only have 8 GB of memory at the moment, because one of my sticks went bad a couple months ago. I think the remaining stick is fine because I have no other issues aside from this one. I watched memory usage in Windows task manager while I was switching platforms, and it always hovers around 70%, so it seems like memory is being managed OK?

Is the issue that I’m running out of memory? Is there any way I can work around that if that is the issue? If it’s not memory, what else could be the issue?

DXDiag information (abridged) - ------------------System Information------------------ Time of this r - Pastebin.com

Thanks for any guidance.

  • Joker

UPDATE: The crash is more general than just switching to Android. It also started happening in other places, in other projects, especially during app build. Seems to be more of a general system instability issue, although Unity is the only thing that seems to do it. See other update info in my answer below.

Update, the most promising fix I have for this so far is resetting my BIOS settings to default. I’m using a motherboard that has some “easy overclock” settings, and of course one of the first things I did was reset the performance level to “Normal,” thinking that was the same as removing overclock. But maybe that wasn’t the case. I reset BIOS to defaults and didn’t touch the easy overclock (even though it still says Normal) and that seems to make a difference.