Resetting Particle Systems not working after 5.3.1

Hi guys, previously the code below would reset a particle system, but after 5.3.1 it no longer seems to work?

_ps.GetComponent().time = 0;
_ps.GetComponent().Play();

@Jackal16 @DenisM I have got around this by using ParticleSystem.Simulate and ParticleSystem.EmissionModule.enabled.

Here is an example snippet from my code, it plays the particle above a certain speed and stops it emitting below that speed. It’s a particle in Local Space and looping but this works on non looping particles also. Hope this helps. DenisM, Might be worth updating bug 756971 with this info if it works for you.

ParticleSystem ps;
ParticleSystem.EmissionModule psemit;
void Start () {
	ps = GetComponent<ParticleSystem>();
	psemit = ps.emission;
}
void Update () {
	if (GameControl.Instance.getMph()>useAboveSpeed)
	{
		if (!ps.isPlaying)
		{
			ps.Simulate(0.0f,true,true);
			psemit.enabled = true;
			ps.Play ();
		}
	}
	else
	{
		if (ps.isPlaying)
		{
			psemit.enabled = false;
			ps.Stop ();
		}
	}
}

The particals seem to be stuck at their end of life time after playing for first time.
When i set the simulation space from local to world and deactivate the attached gameobject and activate it again the particle system works ok. If i turn on loop It also keeps playing.
Resetting the time has no effect for me also.

Got the same issue. Seems like a bug.
Opened ticket https://fogbugz.unity3d.com/default.asp?756971_ukumtus3pui9h3qu

This is fixed in patch 5.3.2p1 due out later this week

I took @alternative_richie 's example and modified it a bit to work for my system. The problem I had with the original is when the button was pressed I did not want the existing particles playing to disappear. So my bracketing the simulate and enabled in the isplaying statement is only fires when there is no particles on the screen which appears to be when the bug is happening. Took me awhile to find this thread. Thanks a bunch.

Example when a button is pressed

if (isBraking)
        {

            isBraking = false;


            if (!leftExh.isPlaying)
            {
                leftExh.Simulate(0.0f, true, true);
                lEmit.enabled = true;
                rightExh.Simulate(0.0f, true, true);
                rEmit.enabled = true;
            }
            leftExh.Play(true);
                rightExh.Play(true);

          

            
        }

When the button is released

if (!isBraking)
        {
            isBraking = true;

                Debug.Log("Stop triggered");
            
                leftExh.Stop();
                rightExh.Stop();
            
            
        }

GameObject_ParticleSystem.SetActive(false);
GameObject_ParticleSystem.SetActive(true);

Works for me Unity 5.3.2