Resolution dialog opens twice when game is run from the .exe file

I’ve got a strange issue with the resolution dialog on Unity 2017.3.0f3.
When I run the game from the .exe file, the dialog window shows as normal, but after I click ‘Play’ the dialog appears the second time instead of game running. Hitting ‘play’ on the second one through start the game as normal.
This problem appears only with the .exe file, running game from Steam opens the dialog only once.
Does anybody have a clue how to fix this?

I’ve never heard about something like this… You should check what kind of build are you compiling. Check also console while runing a developoment build to see what is happening. Did you tried to build it for diferent platforms?

You can always reinstall Unity and download again all addons for builing for Windows, maybe some file is corrupted…

Try it and explain what you get.

If anyone will have the same issue (from the testing department prehabs;))
It is caused by game’s being integrated with Steam. Launching it directly from .exe is not the default behavior so it is checking if was opened via Steam.
If not the app is relaunched with Steam and that was the case why I got the second resolution dialog.
However I don’t find any way to disable that window with code to prevent this, very specific and minor, issue.

same issue!,I have the same problem!