Resolution failed Failed to fetch the following dependencies: com.google.games:gpgs-plugin-support:+

I have been getting this error and would love some help fixing it!

What’s Wrong:

I am trying to integrate Google Play Games into my Unity project. When I build an APK and attempt to log in, I get a class not found exception:

ClassNotFoundException: com.google.android.gms.games.PlayGames

I think this may be due to the fact that the External Dependency Manager is failing to resolve, giving the error in this question’s title:

Resolution failed

Failed to fetch the following dependencies:
com.google.games:gpgs-plugin-support:+

What I’m Using:

  • Unity 2020.3.35f1 w/ built-in JDK, SDK, and Gradle
  • Google Play Games 11.01
  • Firebase Auth & Firestore 9.1
  • Unity’s debug key for my unpublished app (the app is set up with the debug key in the Google Play Console)

What I’ve Tried:

  • Upgrading my Unity from 2020.3.25 to .3.35
  • Using a custom Proguard file
  • Downloading JDK 1.8 from Oracle and using that instead of the built-in
  • Re-importing the Google Play Games plugin after importing all the firebase plugins
  • Ensured that spec="com.google.games:gpgs-plugin-support:0.11.01" is in my GooglePlayGamesPluginDependencies.xml.

Any ideas or help that anyone can offer? It seems a few people have similar issues but said issues never get resolved. (or when a solution is offered it doesn’t work)

2 Likes

The issue was that my GooglePlayGamesPluginDependencies.xml was pointing to a directory that did not exist.

This comment’s fix worked for me:

  • open the file Assets/GooglePlayGames/com.google.play.games/Editor/GooglePlayGamesPluginDependencies.xml
  • change line Packages/com.google.play.games/Editor/m2repository to Assets/GooglePlayGames/com.google.play.games/Editor/m2repository
  • run Android Force Resolve

Thanks You So much. you saved my day.