Resources.Load returns null in a build, but works in editor

Hello Everyone,

I recently updated my project with a new high res art and I am experiencing a problem now. Resources.Load returns null in a build, but works in editor. I tried builds for Windows and Mac that were built using 3.4.2 and 3.5.2.

When I remove half of art files from Resources folder builds are working perfectly. Also I reimported all assets a couple of times and it didn’t help.

It would be great to get some direction or hear your thoughts about this problem. Any help will be appreciated.

Thank you very much,


Update #1: Any clues? I would really appreciate some help in here.

You need to define and assign it appropriately… For instance…

myMaterial.mainTexture = Resources.Load(("carTextureHires"), Texture2D);

It is fairly well summarised here in the manual

Very late to the party, but I had the same problem (as in, Textures where depicted properly whilst running from the editor, but where null (not found) when executed from the build) and solved it by copying a separate Assets/Resources folder with the relevant Textures inside to the same location where the executable build was located at (e.g. if your build is at C:\Files\Something then you would also have to copy a version of your Assets/Resources folder there).

Hope this helps.