Rewired: TypeLoadException after upgrade to version 1.1.19 (Unity 2017)

Hello!

I wanted to update Rewired to version 1.1.19.0 or higher because of the PlayerController functionality.
When I try to import Rewired into Unity 2017, I first get loads of compile errors from ExternalTools. After I resolve these I go back to Unity and try to run the Installer. Nothing happens. Instead I get an error:

System.TypeLoadException: Could not load type ‘Rewired.ReInput’ from assembly ‘Rewired_Core, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null’”
This error happens everytime when the project is opened and when I click on an object that has a Rewired InputManager script on it ( in UnityEditor.EditorAssemblies:ProcessInitializeOnLoadAttributes() , also at Assets/Rewired/Internal/Scripts/Editor/CustomInspectors/CustomInspector_External.cs:19 and Assets/Rewired/Integration/UnityUI/RewiredStandaloneInputModule.cs:1108).
I cannot access the InputManager anymore, which is a huge issue.

I tried the same in Unity 2018 - no issues there. I tried to fix the compiler errors in Unity 2018, exported Rewired from that project and imported it into Unity 2017, as I thought the exception might happen because the Installer wasn’t able to run because of the compiler errors. This didn’t help.

Steps to reproduce:

  1. Create new Unity 2017 project.
  2. Import Rewired version 1.1.19.0 or newer.
  3. Fix compiler errors in ExternalTools.
  4. TypeLoadException → cannot run installer, cannot access InputManager

Is this a known issue, or is it possible that the new Rewired versions do not support Unity 2017?

Thank you for your support!

Cheers,
Kati

(Tested in Unity 2017.3.0f3 (reproducible) and Unity 2018.1.0f2 (non-reproducible))

I finally fixed the problem. The issue was that the Rewired version I used was not downloaded in Unity 2017 but 2018, therefore it downloaded a Rewired version that only works in Unity 2018.

Downloading the Rewired package in Unity 2017 fixed the problem!

Have a nice day everyone!