Ridges on terrain with lowering/raising height?


Hi, I’m fairly new to Unity so hopefully this is a straightforward fix. I’ve found that since updating to the new version of Unity (and making no other changes to the terrain settings) raising and lowering terrain using a builtin default round brush gives me these weird blocky ridges such as the ones pictured below. I created a new terrain than the one I had been using before and used the default settings but wasn’t able to fix it. Terrain smoothing doesn’t work. I’ve looked around online but can’t find others experiencing this issue or any kind of fix.

I’m hoping I just have to change some of the settings–have played around with detail resolution but I see no difference. Thank you for your help.

I solved it–had to check the box marked “draw instanced” under settings. I also made sure to use a 16-bit heightmap based on a suggestion I found online, but I hadn’t been before, so not sure whether that was the problem.

Really confused why “draw instanced” would change things, if someone knows why and can explain, but glad it’s solved either way!


i’ve found that after using the ‘smooth terrain’ tool and then saving, for some reason it instantly changes the terrain to the blocky/ridged 8-bit version! Submitting a bug report. Very strange.

–EDIT 2–

Fixed again, hopefully for real this time! See here: https://forum.unity.com/threads/terrain-weird-bug.604726/

Basically it’s an OpenGL problem and if you run into this, switch to Metal in player settings (make sure you have the support enabled box checked).