Rigidbody2D AddForce not working

I know this is a pretty popular question, since i have spend the last hour googling how to fix it.
I can’t get Addforce to work. I tried it in the game i am making, and it didn’t work. Now i have tried to isolate the problem, by creating a test script, attached to an object with a rigidbody, but still doesn’t work. It’s the first time i have had this problem with AddForce.
The test code i wrote is the example provided by unity: Unity - Scripting API: Rigidbody2D.AddForce

Here is my code:

using System.Collections;
using System.Collections.Generic;
using UnityEngine;

public class test : MonoBehaviour
{

    private Rigidbody2D rb2D;
    private float thrust = 1000f;

    void Awake()
    {
        rb2D = gameObject.GetComponent<Rigidbody2D>();
    }
    
    void FixedUpdate()
    {
        rb2D.AddForce(transform.up * thrust);
        rb2D.AddForce(transform.up * thrust, ForceMode2D.Impulse);
    }
}

Attached to the object in the picture.
[201243-hjæælp.png|201243]

The object doesn’t move at all, I’m pretty sure i have done everything required for AddForce.
Can anyone see the problem?

Never mind, i think i fixed it. My problem was that the rigidbody Body Type was set to kinematic. I set it to dynamic, and changed the gravity scale to 0.