ROG Ally can't run HDRP builds from v2023, instant crash

On Asus ROG Ally (which is getting quite popular amongst gamers lately), builds of HDRP projects crash right on start - device is nonresponsive for a while and then the game shuts down. When built with Unity splash screen, the splash screen is shown fine, freeze on a black screen after that and then crashes/quits.

To replicate - create a simple HDRP project (just the "3D HDRP Core" template is ok), create a build, try to run on ROG Ally.

Unity versions tested: 2023.2.0b11, 2023.2.0b14

Build from Unity 2022 does run fine it seems (at least with the default project). Our project is build on 2023 though because of features not yet available in 2022.

Of note might be, that even Unity editor itself doesn't start for the project on Ally itself (although it's pretty much a perfectly normal Windows machine inside), crashes while loading the editor.

Tested a build running both DX11 and DX12 just in case, neither works.

Including logs for both our game (though more could be wrong in there, who knows, but it works fine on all other devices), and from the empty sample HDRP project for convenience.

9432671--1322597--OurGame_Player.log.txt (40.8 KB)
9432671--1322600--SampleEmptyHDRP_Player.log.txt (30.4 KB)

There btw is no "/Crashes" folder, only the log file. It doesn't show the traditional "unity crash window with a progress bar" which I believe is what gathers the crash info to the crashes folder, it only kills itself without that, and only thing present is the Player.log file

Update: it seems to be able to run builds from 2023.3 though -> tested with 2023.3.0a10

but ngl, I'm quite scared to use an engine alpha

The last line of the log file says:

A crash has been intercepted by the crash handler. For call stack and other details, see the latest crash report generated in:
* C:/Users/ladty/AppData/Local/Temp/DefaultCompany/AsusROGAlly2023Core/Crashes

Is there nothing in that folder?

I wonder if you're running into something similar to

Which version did you upgrade from where it worked previously?

I'm sorry, the folder simply does not exist, I would have posted it otherwise :(
And sadly, we didn't upgrade from a version where it worked, we've been on 2023.2 for a long time now, but only now got our game out and received multiple reports of not running on ROG Ally. So we got the Ally and started testing ourselves, turns out not even the default hdrp project runs there (build from 2023.2) and that it's not directly the game's fault.

But a test empty HDRP project made using the latest 2022 works, as well as made using 2023.3
(in our case, we can't go back to 2022 though, and 2023.3 feels very risky... but mb we'll try pushing a build using that and see what happens :()

I tend to assume that for systems like these, the vendors unfortunately typically preload the system with their own graphics driver versions for no real tangible benefits other than, say, blinking some lights or providing a branded „experience“. If that is the case be sure to try the official AMD drivers.

This looks like a graphics driver crash to me. Could you try running a build made for D3D12 with debug layer enabled? To do that, you first need Graphics Tool optional Windows feature installed, as outlined here:

For Windows 10, to create a device that supports the debug layer, enable the "Graphics Tools" optional feature. Go to the Settings panel, under System, Apps & features, Manage optional Features, Add a feature, and then look for "Graphics Tools".

Note although it says Windows 10, same thing applies for Windows 11.

Then, run the player with these command line parameters, capturing the log in between runs:

First run:

-force-d3d12 -force-d3d12-debug

Second run:

-force-d3d12 -force-d3d12-debug -force-d3d12-debug-gbv

This should hopefully shed more light on the situation.