rotate with alt doesnt work

this makes me mad, sometimes the alt button doesnt rotate the screen anymore, should be very easy to answer, please help. (if I hold alt and move it moves it left and right)

There’s a tiny padlock in the top-right hand corner of the scene view:

Try clicking that

Try to rotate with the Right Click and then use the Alt+Left Click again. This should fix the problem. Happened to me couple of times.

UPDATE Sep, 2nd, 2010 Some of the assumptions in my previous post are erroneous. I hope to put this issue to rest with this much shorter and concise post. I left the other post for history purpose, a mod can delete it if history is not necessary.

ALT KEY ROTATING(Orbiting) WORKS FINE (once one has had better experience with it ;) I have tested it repeatedly. I never got it to fail. Thus the reported problem about the failure of orbiting an object does not exist.

Orbiting an object is accomplished by:

  1. first selecting a GameObject in the view window and pressing F
  2. then ALT-mouseDRAG to orbit the object.

It only appears to fail due to the following 3 scenarios(in any combination):

  1. The center of the pivot is no longer the center of the object you are focusing on. Thus the object you are attempting to orbit appears as if going from left to right on the screen when in fact it is going around in a large circle. Make sure the object in focus is not child or parent of another object that is at a distance in the scene, as the center of the pivot may be mid distance between the 2 or more objects You can either click on an object that will put the pivot near the object you want to orbit, or take the object you want to orbit out of the parent/child state.

  2. The current object selected is the TERRAIN and or the Hand tool is selected, thus no access to other objects in scene. When the terrain is selected, the editor does not allow direct clicking on objects in the scene window thus click on any object in the hierarchy window to get OFF the terrain. Make sure the transform tool is not set to the little Hand as no selection is allowed if on Hand. Note: if the terrain is selected in the hierarchy, you may click any point on it then press F, and orbit that point.

  3. The view vane(x,y,z,perspective, etc scene gizmo) is not in perspective mode Click the vane to set it to perspective mode.

Now you can:

  • click on any object in the scene window, and press F to give it focus.
  • or select object in the hierarchy window, hover mouse pointer over view window before pressing F.
  • ALT-mouseDRAG will now work.

Remember that all 3 scenarios can occur at the same time, thus you will have to cover all 3 points above in some instances.

I think its because you have accidently pressed the cube top right. the three individual axis do xyz pressing the cube does perspective and enables alt. maybe


I used to have that problem, the answer is to click the top arrow of the screen view cube, and click your angle again!

~Gibson of GBSoftware~

You have to do a simple thing … just change the scene-view from 3D to 2D. It will give you rotate option with ‘alt’ key. (In case you are working on 3D project).[94429-capture.png|94429]

I've just stopped using alt completely and use the right mouse button.

ALT KEY ROTATING(Orbiting) problem GO-AROUND (SOLUTION) ...maybe?

My platform - WINDOWS 7 -2.6.1xx Unity (2 button mouse with 3rd button combined with mouse wheel)

  • Please vote up this entry if you find it helpful and select it as the answer.
  • I have reported the issues(BUGs) to the Unity Team. No need to report again.

  • When the problem occurs it is because the center of the pivot is no longer the center of the object you are focusing on. Thus the object you are attempting to orbit appears as if going from left to right on the screen when in fact it is going around in a large circle.

  • No one section alone(below) works always. Depending on the context of your editing session, you may have to cross any of the below suggestions to recover. Even the F key fails at times.

Thus the problem is not that it no longer lets you pivot(Orbit) an object, but that the commands/key sequences to resume the ALT-Orbit in place are not available, until you try any one or more of the sequences I listed below.

Moves I use to recover. (Walk-thrus below)

  • ARROW Keys(UP/DOWN mostly), Mouse(Click and Drag), Mouse Wheel, Mouse Wheel Button,
  • ALT key, and F key,
  • Selecting objects via the hierarchy list, then clicking the Scene TAB, then ALT-LeftClick-Drag ...and Selecting objects by Left clicking them, then ALT-LeftClick-Drag
  • rotating the vane (Unity calls it the Scene gizmo) - the omnidirectional vane at top of screen.

  • ...ALL OF THE ABOVE while swapping from the grab to the move button on the object manipulation tool bar as needed.

If you are unable to recover, make sure to cross use any suggestion in any of the sections. Examples: - You may have to 1st select your object from the hierarchy window if the editor does not let you select via direct click - You may have to swap from the Grab button to the Move button, etc... - Don't forget to try the F key sequence, it works on most instances, but again not guaranteed.

Rotating is really Orbiting... - when you attempt to focus on an object at a particular angle, you are moving the editor's camera about the object. - The entire Scene, terrain, is affected not just the object that you are focusing on. ZOOM in and out (UP/DOWN ARROW keys, Mouse Wheel) far enough to cause the terrain to show on top of the World Grid then use ALT-Mouse Drag to see that in fact you are Orbiting around a pivot point.

ALT-Mouse-Drag means: 1st Press and HOLD the ALT key down, then click hold and drag the terrain to orbit.

I have 2 scenarios with different but related issues.

1. FALSE TERRAIN: I have a special case as I am using a false terrain, a simple flat surface(plane) with a mesh, a mesh rendered, and mesh collider where I place all my objects to test before copying them to a real terrain created with the Terrain-Create option in the Terrain menu.

2. REAL TERRAIN: I created with the Terrain-Create option in the Terrain menu and put 3 spheres(1, 2, 3) about 1 inch apart or so across the screen. It has a the standard Terrain Script(not editable, but can be tweaked in the Inspector)

In the real TERRAIN,

  • click sphere 2(the one in the middle) then hit F, now ALT will pivot the camera around the center of that sphere.
  • Use the Mouse Wheel to zoom in and out to adjust nearness of the object(sphere)
  • Click sphere 1 or 3 and see that ALT still rotates around the center of sphere 2
  • Hit F and the pivot will now shift to the selected sphere(2),
  • use ALT and see that it pivots around that sphere.

On a complex object click on any child object that is near the center of the complex object to get the best pivot. You can also click the parent object in the hierarchy window(then click on the Scene TAB) and ALT-Mouse Drag

Odd behaviors I have experienced

  • Restarting Unity, or Logging Off the WINDOWS user, or rebooting does not resolve the issue. When starting the editor anew, even if you have not saved your Scene, the problem persists and must be resolved before continuing to use the editor effectively.
  • After using the orbiting tool you may be left unable to select objects by clicking on them directly even if the toolbar Move button is clicked... select the object via the hierarchy window to resume that functionality. You should from that point be able to select directly with the mouse(until it fails again.)
  • On a complex object click on any child object that is near the center of the complex object to get the best pivot. You can also click the parent object in the hierarchy window(then click on the Scene TAB) and ALT-Mouse Drag, but choosing the parent may or may not pivot on the exact center of the complex object.
  • If you load a new Scene the current state of zoom is applied to the new Scene not the state that you left that Scene in when saving it the last time. Thus expect to have to zoom in or out a lot before you may see any of the objects you wish to focus on in the newly loaded Scene. ...or simply use select object from the hierarchy window and hit F
  • If you inadvertently hit the MouseWheel button while holding ALT or F, the scene may go into a very far ZOOM where the objects are minute.

  • Note: The F key does not always bring up the selected object in the same proximity/angle/zoom

  • As I was testing these issues between 2 scenes(false terrain and real terrain), a complex object made of 4 simple cubes landed in my other scene. This is an object that I did not click nor got near in its original scene, an object that was created days ago and was not visited for that long. I have no idea how it crossed over. UPDATE: Sep, 2nd, 2010... while I was sweeping with the mouse to shape the terrain, I was inadvertently and unknowingly grabbing the objects from the projects window due to mishits of the mouse pointer.

These odd behaviors show that the Unity editor is holding information in temp files, that it writes to on the fly. It may also retain information in memory and gets out of sync with the editing session.

ERRORs: Error that kicked out on the console while bringing the object in focus very close at bottom of screen

Assert in file: Assert/Standard Asserts/Camera Scripts/SmoothFollow.js at line 35 0 UnityEngine.Debug:Log(Object) UnityEngine.MonoBehaviour:print(Object) SmoothFollow:OnGUI() (at Assets\Standard Assets\Camera Scripts \SmoothFollow.js:35) UnityEditor.EditorGUIUtility:RenderGameViewCameras(Rect, Rect, Boolean, Boolean) UnityEditor.EditorGUIUtility:RenderGameViewCameras(Rect, Rect, Boolean, Boolean) UnityEditor.GameView:OnGUI() System.Reflection.MonoMethod:InternalInvoke(Object, Object[]) System.Reflection.MonoMethod:InternalInvoke(Object, Object[]) System.Reflection.MonoMethod:Invoke(Object, BindingFlags, Binder, Object[], CultureInfo) System.Reflection.MethodBase:Invoke(Object,


With the newer version 4.3:
Maybe you are just in another perspecive…
So press 1 or 2 or 3… maybe u come back to the right one

I just had this issue, but I found out that I accidentaly have clicked on a little 2D button above the Scene view.

On linux, use Windows+Alt+LMB

You have selected 2d instead of 3d :slight_smile:

At the top of your screen look at where you see scene, game, asset store. Now below that is shaded, 2D.

If the 2D is pressed down you need to click on it as there is nothing to rotate in 2D. (That was my problem at least)

I had the same problem. I tried to hold Windows key on the left of the left Alt key + left click mouse, it works.

I have the same problem using the right mouse button. The only solution I have is to restart Unity.

I have the same problem using the right mouse button. The only solution I have is to restart Unity.