Rotation in animation missing when legacy enabled

I have a weapon with 3 animations for idle, sprinting and attacking. They are all called via code (JavaScript). All of the code works and looks good when in the animation window, until legacy is turned on. With legacy on, they lose the rotation that they had, but keep all transformations. The animation without legacy will not play in scene as they are “not found,” and with legacy the do play, but just don’t have any rotation that is necessary for them to look good. I have a tutorial scene that I was doing when learning Unity and in that the animations work perfectly with legacy enabled, and the code used is the same, so I know it isn’t code issues. I’m using Unity 5.3.1f1 Personal Edition.

Alright, thanks to another member of my team, the issue was solved a few days ago. It seems that in the rotation options of Unity Animation, it needed to be set to Euler Angles (Quaternion Approximation) under the Interpolation options. Legacy worked fine after that.