Safari 6 - Web Player (weird behaviour)


Has anyone tried Unity Web Player on the latest Safari? The first person controller seems to be doing weird things on it. I’m loading the same build as before I upgraded Safari (in fact the OS (Mountain Lion)). It worked fine yesterday before I did the upgrade. Also, it’s working fine on Chrome right now. So I’m suspecting it has something to do with the new Safari.
To be specific, when I press WSAD, the first person controller starts to walk away on its own and can’t be stopped…

Anyone experiencing that or has experienced that?


seem a Safari problem not Unity, could be better ask to Safari forum

I’m experiencing exactly the same thing. Prior to Mountain Lion, Unity Player worked fine in Safari. Since Mountain Lion, it’s continued to work fine in Firefox and Chrome.

In Safari 6, the first input per axis seems to “stick” forever. Or perhaps input axes can only increase, and never decrease. Either way, it certainly seems to be an integration bug between Unity Web Player and Safai 6. My current version is 6.0 (8536.25).

This is indeed a bug with Safari 6 on Mountain Lion, we investigated this and reported a bug to Apple using the Apple radar service, unfortunately we didn’t find a good way of implementing a workaround so we hope Apple can resolve this asap.