Scale animation with model

Hello,

I’ve been following the Unity’s official Mechanim tutorial which teaches how to animate a robot to run, jump, roll etc. ( Unity 4.0 - Mecanim Animation Tutorial - YouTube )

However, the scene I’m trying to use this with is quite large, and I have to scale up my custom character model about 10 times. When I animate it with Mechanim using the animations you get with the tutorial, the animations are reeeally slow on the character.

Is there any way to “scale” the animation with the model? I tried changing animation speed, but that just makes it look silly. Is there a way to modify the amount of distance the animation covers, or something?

Thanks in advance for the reply.

You should scale the model in the import settings. Select the GameObject with the SkinnedMeshRenderer. Click the mesh. Clicking on the object that contains the mesh will change your Inspecter window to the import settings for that file (fbx, obj, et al). Increase the Scale Factor by a factor of 10 there, and you should be good.

Edit: Upon reading your question again, it seems that you might be moving your mesh via the animation? This is generally a bad idea. Generally speaking the animations shouldn’t have translation keys; instead you should move your object using Unity. My above suggestion may not fix your issue if this is the case.