Scene is zoomed in when I click play?

So continuing my game, and I found that when I click the play button, the whole scene zooms in abnormally, which is not what the camera preview says it should do…
The one script I can think of that may be causing this problem is that during runtime I make the player a parent of the camera, but this worked great for a while.

I had a similar issue. It seems that if the editor scaling settings are set to a specific resolution, the game window will try to zoom to that resolution now when in play mode.


For me the fix was specifying an aspect ratio instead of a specific resolution. For example, 9:16, instead of 1080x1920.

130167-capture.png

This one is a unity bug and will happen to you after you install unity.
It will automatically zoom in on you scene once you hit the play button.
Its really annoying and they still doesnt fix it on every unity update.

Check to make sure that all the setting for your game-view are correct particularly “Scale”, next make sure your camera’s field of view isn’t set too low.
Make sure the aspect ratio matches your screens resolution.


If all this is correct, either try to find anything in your code that changes camera settings or upload the suspected script (or parts of) so someone can find the problem.


When the simulator is zoomed, it unintentionally affects the Unity game view, causing an undesired zoom effect. To mitigate this problem, ensure that your simulator is set to a zoom level of 1. This adjustment should decouple the simulator’s zoom from the Unity game view, preventing any unwanted synchronization. By setting the simulator’s zoom to 1, you eliminate the interference it has on the Unity game view. This simple adjustment should restore the expected behavior without the undesired zoom effect.