Scene loads in editor but not on Android build

I recently upgraded a Unity project from 4.6 to 5.3.1f1. Not unexpectedly, there were some issues involved in doing so. I have cleared up all of the errors and my project works fine in editor, however when I try to build to an Android device (Nexus 7 and Samsung Galaxy s5) the Game scene will not load.

I have a Splash Screen scene that loads into a Main Menu scene which works fine. Whenever I try to go from the Main Menu to a Game scene, the game completely freezes while still on the Main Menu. I have tried waiting several minutes to make sure it wasn’t just taking forever to load. Tried out the profiling tool and it comes to a halt as soon as the Start button is pressed. I have disabled every game object in my scene individually and all at once and it still will not load.

I tried loading a new empty scene instead and that seems to work fine.

Really stuck on this and would appreciate any help!

I seem to have fixed the problem, though the answer doesn’t really make sense to me. I traced the issue to a script that had a public AudioClip that was not being referenced anywhere in code. Commenting this out makes the scene load fine.

Strangely, there were no errors or warnings about the variable being assigned but never used or anything like it. Looks like Unity just failed silently specifically with building on Android.


@midgardweller How did you diagnose this problem? I’m having a similar issue and wondering how you backtracked to find the underlying cause? Hoping I can repro your results.