Scene will not render in build but will render in editor

I’m working on upgrading a current project to the HDRP.
Everything has mostly gone fine, and in the Editor everything looks great.

However, trying to make an x86-64 Windows build yields… this:

I’m at a loss. The default scene renders fine, and I can tell the scene is being loaded fine (it’s semi procedural) because all my scripts reach their ends with no exceptions (and it works in the editor!).

To give you an idea, most of the geometry you see is loaded in from an asset bundle. The counter tops, windows and walls are drawn procedurally. All the materials are being loaded from Resources.

You can only see the outer walls too, there’s no ceiling, inner walls, etc.

What the heck is going on?

Edit:

For comparison, I have tried:
Placing a cube in the scene from the editor.
Creating a cube via script.

Both work in the editor, but only the former works in the build.

public IEnumerator PseudoCodeLoad()
        {
            var gameObject = GameObject.CreatePrimitive(PrimitiveType.Cube);
            gameObject.transform.position = Vector3.one; 
            Debug.Log("Reached end")
            yield break;
        }

Solved, it appeared to be a draw order issue.

I hadn’t configured my shaders correctly, and when everything called in, all geometry except the external wall (because I reapplied a new material at runtime) was drawing behind the skybox.

Figured it out when I opened the example scene and all the demo objects were rendering just fine… but in-front of my asset bundle objects.