[SCREENSHOT] Why are my lighmapped shadows so blurry?

Check out the shadows cast by these boulders, on my light mapped terrain. They are blurry. perhaps because lightmap resolution is low or perhaps baked bounce intensity is too high. But I dont know where to adjust these settings. In the lighting tab, the only resolution setting I see is under “Baked GI”, called"Baked resolution". Increasing this setting from 20 to 40 and re-baking made almost no noticeable difference. what am I missing? Do quality setting pre-baking determine the bake quality? Before baking, when my real time directional light is enabled, shadows looks quite good. After baking, you can barely see the shape of the shadows. Especially from up close, it looks blurry. I need to re-bake shadows at a higher resolution, but don’t know which settings to change. help me out

Happens to me all the time, did you fix it?

The problem occurs because your terrain has too few uv charts.
You can increase the amount of charts in your lighting settings.
Window > lighting and then increase your lightmap size (atlas size). Make sure your lightmap resolution (baked resolution) is high enough as well.
Change your scene view mode from shaded to uv charts to see the uv charts.