Script attached to 'PlayerWithAuthPrefab' in scene '' is missing or no valid script is attached error when making android build

I’m making an android game. Whenever I try to build the build succeeds but I get some errors

I’m not sure where these prefabs are even located. I did delete some prefabs but these are different.
I tried running the build and the scene loads but I’m unable to control anything. I tried to build a different scene and everything works fine on that one (including controls). The scripts are the same. The prefabs and assets are also the same. I’m not sure where the problem is.

I was getting the same warnings. “‘NoAuthObjPrefab’ in scene ‘’ is missing…”
Building my app for mobile. which worked perfectly in unity.
I noticed that all of the warnings I was getting were based in the same package, the Multi Player HLAPI.

I took these steps, and I no longer have the errors.

Step 1) Pull down the Windows menu and select Package Manager.

144866-tep1unitypkg.png

Step 2) Make sure the Multiplayer HLAPI is up to date. Mine wasn’t but when it is it should look like the image, otherwise there will be a button to update the package.

after that, I built my project with no errors.

After I upgraded Unity to 2019 and tried to build for iOS I got these warnings. I deleted my Library and obj folder, re-opened the project, and the warnings disappeared.

I had exactly the same warnings while building an imported Android project from 2018.3.2f1 to 2019.1.0f2 like your version.
To avoid that, I only upgraded the project to the latest 2018 version (2018.3.13f1) where the build goes right.
Probably it is something related to the new Unity.

Same problem here: moving from 2017.2… to 2019.2.0f1. Actually, I get a number of such warnings, see image below.

. Edit:so basically the same output as the poster!

Same warning.
After build .apk, the program crashed on my phone.

Neither “Multiplayer HLAPI” nor “Delete Library” works.

Unity 2019.4.9f1