Script Execution Order Plus Button Causes Error From Assembly Meta File

Every time that I try and press the plus button to add a new script to the Script Execution Order list, I get this error (manually typed):

ArgumentException: An item with the same key has already been added. Key: Assets/Plugins/Demigiant/DOTween/DOTween.dll.meta

System.Collections.Generic.Dictionary `2[TKey, TValue].TryInsert (TKey key, TValue value, System.Collections.Generic.InsertionBehavior behavior) (at <fb001e01371b4adca20013e0ac763896>:0)

I’ve tried uninstalling and reinstalling DOTween, but it doesn’t change a thing. At the moment, there are no DOTween scripts listed in the SEO Settings. In addition, when I did uninstall DOTween, it through the same error, but for a core Rewired assembly metafile.
Has anyone seen this before? It’s frustrating to deal with since I’m unable to add to the SEO list in the Unity 2020.1 editor.

Hey, I’m not sure if you ever solved this issue, but for people coming across this issue, this page still doesn’t solve the issue, but does point out that manually dragging scripts into the execution order still works. This had been a suitable work-around for me.

Found the reason and submitted a bug report (it’s a Unity 2020 bug). It happens if the project contains a DLL that has two or more MonoBehaviour/ScriptableObjects inside. Here’s a pic from my bug report that explains it: