Scriptable Object issues when inside .dll

Hello all,

I have a few scriptable object classes similar to the one shown below I’m using to store data in my project. My project itself is broken into two .dll’s one for editor code another for run-time code.

Everything seems to work fine in both projects except for the scriptable object inspector windows missing their fields when selected in the editor and the ability to drag these scriptable objects onto other fields in other classes inspectors.

My project runs fine and the scriptable objects are normal when using the original source project, but when looking at the scriptable object in the release project the fields are missing. I’ve attached a picture of the issue as well with the left side showing the release version and the issue (please excuse some of the omissions and blurring as this is for an ongoing project).


System: Windows 10 64-bit

Unity Version: 2017.3.1f1

Dlls: built with MVS 2015 targeting unity .net 3.5 full

Runtime Dll: references UnityEngine, UnityEngineUI and MyDllEditor.dll below

Editor Dll: references UnityEditor

namespace MyDllRuntime
    using UnityEngine;

    public class InfoBlurb : ScriptableObject
        [TooltipAttribute("The title of the piece that this blurb corresponds with.")]
        public string title;
        [TooltipAttribute("The name(s) of the artist(s) who worked on this piece.")]
        public string artistName;
        [TooltipAttribute("The medium(s) used in the making of this piece.")]
        public string medium;
        [TooltipAttribute("Any extra information such as dimensions, etc... are good candidates for this slot.")]
        public string auxilliaryInfo;
        [TooltipAttribute("A short description of the piece this blurb corresponds with.")]
        [TextAreaAttribute(7, 9)]
        public string description;

It looks like this is just caused by the fresh import from the original project. For some reason just deleting the old scriptable objects that were originally imported and just creating a new one through the wizard solved the issue. It now shows it property fields and is able to be dragged into inspector fields again.