Scripts and Objects not working (Solved)

I’ve been working on this game for about 5 months and when I opened it today, everything was messed up. When I go to the inspector when I select an object, this message keeps coming up next to the value: ''The module which implements this component type has been force excluded in player settings. This object will be removed in play mode and from any builds you make.". I tried to create a new project and when I went to the inspector again, this message was still there. Can anyone help me fix this bug or give me advice? Thanks!

Try deleting the library in your project (with Unity closed) then opening Unity to allow it to regenerate the library.
What was the last thing you did before this started happening? Did you install any packages, or upgrade unity?

Replace manifest.json with a fresh project’s manifest.json or from another project

i don’t know for sure but maybe reinstalling unity may help. Its just a suggestion. I once had a problem like this when I tried to build my game. It told Monobehavoir not found … and a lot other errors. But when i reinstalled unity it gave me a successful build.