Scripts not showing in Monodevelop

I have ~17 scripts in my unity project and when i double click on a script to edit it, Monodevelop opens only that script to edit without showing the rest of the project scripts on the left.

Im guessing that the monodevelop just opens the script like any other text editor, but not as integrated unity script editor with all the fancy project related tools.

Its very tiring to open every script one by one to edit them if i want to see those script!s while editing.

any ideas how to restore the script list ?

P.S. The unity project file ( [40432-assembly-unityscriptunityproj.txt|40432] ) has all the scripts names mentioned.

Edit: tried resyncing, reinstalling unity, reimporting assests, selecting external script editor.

Edit2 : tried browsing to .sln file.

SOLVED! Did a super clean reinstall, deleting all the regs, appdata files and anything thats monodevelop and unity related. After that after opening my project (for some reason) i had to re-enable all the unity add-ins to get everything working agian and there was I happily browsing my project scripts.