Scripts Not Updating in Unity 2017.2.0f3

Hello all, this is my first time asking a question here. I know there are a couple other people asking this but I’m not seeing my exact question…

I’m using Unity 2017.2.03f on Windows 10 with Monodevelop. I’m taking lessons and making example games from a course on Udemy, and up until recently everything was going great. However the last few example projects I’ve been working on, I’ve begun to notice that when I save and update a script in Monodevelop, it doesn’t update the script in Unity that’s already attached to an object unless I click the gear on the script and hit reset. That is really irritating for a few reasons… mainly because if I have the script applied to several objects, I have to reset it on all of them, and sometimes I forget to do it on one. Also if this script references an external object, I have to drag and drop the object back into the inspector window in Unity, which gets tedious, tiring, and downright frustrating when I’m trying to figure out what is causing a bug, and forgot that I didn’t pass in the text mesh when I reset the script for the 8th time.

UGH!!! Okay, so…

What can I do to potentially resolve this? I’ve heard people say that reinstalling Unity doesn’t help, but I’m wondering if perhaps trying out the beta version would be a good idea? This is seriously so frustrating… if I were working on larger project I was planning to release commercially, this would completely halt my production for fear of screwing up my game beyond repair for the above reason.

I’ve seen some people saying something about how this happens in projects that use meta tags, and to make sure your meta tags are not set to hidden. I have verified the meta files in my project directory are not set to hidden. I also heard some versions of Unity are able to right click on the script in the assets folder in Unity and click something like resync monodevelop project, but I don’t see the option to do that anywhere. If someone maybe has a screen shot of this option in 2017.2.03f they could share that would be an awesome temporary work around for me.


What else can I try doing? :frowning:

Thank you for taking the time to read/respond to my post!

Update: Still trying to resolve this. At this point I’ve tried just about everything suggested in the other threads on this board. One thing though is I’ve noticed most of the people who get this issue are on Mac, but I’m on Windows 10…

Do the devs ever post answers on here? I guess at this point I’m wondering if there is a different version of Unity I can download where this issue doesn’t happen? But also I’m concerned about updating to the beta version because I was reading that the transform component has changed somehow, and I’m worried that the example code for the lessons I’m taking on Udemy would stop working.

Has anyone tried the beta? Do you have this issue in beta, and is the beta a huge difference from the current version?

Thanks again!!

Update: Tried reinstalling Unity, and installing the beta version, but still receive the same error… going to try using Visual Studio instead of MonoDevelop… this is unbelievable the issue seems to have been around in last patch too, and I’ve read thread after thread of people complaining about it… can someone possibly recommend a version that doesn’t have this issue?

Did you tried Edit → Preferences → General → AutoRefresh ?
Some time ago this check box was somehow turned off and I spent a lot of time trying to understand what was broken.