Scroll Functionality Issue When Transitioning Between Scenes

Hello Unity community,

I’m encountering a puzzling issue with my Unity project that involves the Scroll functionality within a form. Everything works perfectly when I run a scene in isolation. However, the problem arises when transitioning from one scene to another; the Scroll functionality stops working as expected, while all other form elements remain responsive.

Problem Description:
I was recently working on an old project (-+2018), in my Unity project, I’ve added a new form that allows users to scroll through various options and questions. When I run a scene independently, the scrolling within the form works smoothly. However, when I transition from one scene to another (e.g., from a menu to a settings screen), the Scroll functionality suddenly ceases to function.

Notably, all other elements within the form, such as buttons and text fields, continue to respond to user input. Interestingly, the scroll bar’s side areas still function correctly when clicked, but the scroll bar itself doesn’t respond to touch or mouse input.

Here problem (on transition scene):

Additional Information:

  • I have checked and confirmed that the EventSystem and UI elements are correctly configured in each scene.
  • The problem seems to be related to how the EventSystem behaves when transitioning between scenes, but I’m unsure how to resolve it.
  • I’ve also tried various solutions, including re-importing assets and modifying the StandaloneInputModule settings, but none have resolved the issue.

Unity Version: 2021.3

Platform: Windows 10

Build: Android

Tested on: Huewei P30

Additional Context:

I’ve provided a detailed description of my problem, but I’m still unable to identify the root cause of this issue. Any help or suggestions would be greatly appreciated. If you’ve encountered a similar problem or have insights on how to tackle this issue, please share your expertise.

Here’s how i make my survey:

Thank you in advance for your help and time!

After Days of test and error i figured out the problem, im using in the previuos scene a RigidBody FPS in this case implements a simple flag to prevent to use cursor or touch, in this case i dont know how this script trascends to the next scene beause im not using a FPS in the survey scene, anyways it works now. :'v

As a new user i was to able to add only one image, here is a comment to complement the post.
Here Survey working: