SECURITY Issue - Unity game tries connecting to an unknown IP address


Some time ago, I made a game using Unity’s Space Shooter tutorial to learn and test stuff. Today I worked on the project again; upgraded the project to Unity 5, improved it and made another build.

After testing the game, I let the game opened on its “Game Over - Press ‘R’ to Continue” screen and left my desk to do other stuff. When I returned, I just randomly clicked in my game when suddenly, my Comodo Firewall shows me the game tries to connect over HTTPS to some unknown IP address. What the heck???

Needless to say, I’m not in a happy mood. I ran a quick IP check and it seems to point to some Amazon server (

=== COMODO Firewall Logs - Firewall Events ===
Application: D:****\myGame_Win32.exe
Direction: Out
Protocol: TCP
Source IP: host (PC’s local IP address)
Source Port: 51503
Destination IP:
Destination Port: 443 (aka HTTPS)

I’d really, really like an explanation… I built the game from scratch, hand coded every single scripts and there’s no networking component in my game.

What’s going on? O_o

NOTE: I can replicate the issue too; while typing this question, I left my game opened, A while later, Bam! Again, attempts to connect to that same IP address twice.

-Unity 5.4.1.f1
-Windows 10 Pro 64bit

Did you try and just going to the address? Anyways it resolves to: You can read the privacy policy and all that jazz at that site, you can be in an unhappy mood but you agreed to it.