See-through Imported Mesh

When I import my mesh, the polygons on the side of the object that the camera is viewing them from just disappear. When I look at the mesh from one side of the object, I can see through all of the polygons on my camera's side to the other sides of the mesh. When I move around to check the other side, the same thing happens. Basically, I can see through the polygons, into the center of an object I imported.

Possible reasons:

  • The normals of certain polygons are inverted, open in your 3d prog and see if you can turn on backface culling to find the offending polygons (short explanation, for performance reasons polygons have an inside and an outside, the side is determined by calculating the normal of the polygon, insides are normally not drawn).

  • You are too close to the camera. Possibly your near view plane of the camera is set too far. See camera properties in inspector.

The first problem can be solved with modifying the shader such that it does draw the insides as well but normally the solution is to fix the model (placing Cull Off at the right place in the shader should do the trick).

Thank you for the quick answer. I've realized that the vast majority of my polygons are inverted, is there a quick way to fix that? Sorry, I'm kind of new to this. I have access to Autodesk Maya 2010 and Autodesk 3ds Max 2010, the mesh was created in Maya.

I have had this problem before when making spheres into Holodeck type objects.

The common solution to textures not mapping to interiors is to reverse the normals in your polysoup app. Here is the solution for fixing your mesh in Maya (2009 or 2010).

In Maya:

  • Select your Mesh
  • Select Normals Menu (Make Sure you are in the "Polygon" Menu Set)
  • Choose Reverse with Options Box
  • The settings I use are - Select All faces in the Shell and Preserve User Normals Direction.

Hope this helps Maya Users

In Maya, turn off two sided lightning. Every face that will show black should be inverted. Select the black faces, and select reverse normals from the menu.

Can you give an example of the object you're creating? A room? A character? A landscape? If you're working on an interior level(i.e a room), you'll need to have your normals pointing inward - otherwise, when you play the game, the player will be able to see through your walls.

-Lincoln Green

Thank you for the help, and I figured out how to reverse the normals on my character.

I have a related problem. If the camera is too close, some parts of the mesh don't appear, like for example is it is a man, the legs are invisible. But If I move the mesh a little bit far, they show. My concern is that they are between the far and near clip and if I see the scene editor, they are inside the "pyramid" formed by the camera (they are in front of it), so how could I expect to have a close up of the face if it doesnt show anyway.

Pelase help