Semaless Textures

Hey I have 4 seamless textures but when I jump you can tell that they are tiled. Is there a way that I can make it look blended together so it looks better or not tiled when it realy is.
Thank you and have a fantastic day!

There are a ton of reasons why seams may be appearing. It might be helpful to provide more information about what meshes you’re using or how the textures are being stitched together.

I recently did a tiled 2D game where seams were appearing because mipmapping was enabled for the textures, causing seams to appear when zoomed out. Disabling mipmapping worked for me.