Sequences package causes very long delays

Having the Sequences package installed causes a large delay for my project to finish opening.
It holds at “Waiting for Unity’s code in Unity.Sequences.Editor.dll to finish executing.” This pop up shows once the project is loaded and then click anywhere in the project.
The delay appears to increase the more sequences I create or files I add to the project.
I’ve used both Sequences 1.1.0 on 2022.1.20f1 and Sequences 2.01 on 2022.3.3f1. It takes 6 minutes to open load a project. When the project was smaller it only took 30 seconds but gradually increased as the project got bigger over time.
I tried deleting all of my sequences but it did had no effect.
However the project loads instantly once the Sequences package is removed.
It’s actually faster for me to remove the package before opening the project then reinstalling the Sequences package after it’s been loaded. Removing Sequences before and reinstalling it after takes 1-2 minutes vs 6 minutes. But this is not an ideal solution.

What exactly is the Sequences package doing that cause these load times? Is there a way to decrease this delay?

Thank you.

9428354--1321739--sequences delay.jpg

Hi @YoshYoshKo !

Thanks for your thorough report.
Seems indeed you hit a concerning issue.

Would you mind reporting the bug using Unity's bug reporter (see ?
That would help up investigate the issue with all the context.

Thanks a bunch !

Unity 2022 LTS - migrated my 2021LTS project, that worked flawless before. Now, I have sequenceassetindexer popup coming up as with @YoshYohsko: same thing :/

I have the same issue. It steals about half an hour every day. Any solution for this?

Hi there !

Thanks all, for the new reports, it confirms there is something shady here.

Could one of you file a report using Unity's bug reporter (see ?
Having access to the context and/or a project that demonstrates the issue would be very helpful.
I was personally not able to repro for now.

Also can you also clarify on which platform you are, which specific versions of Unity's AND Sequences you observed the issue ? (ex: Unity 2022.3.15f with Sequences 2.0.1).

And about your Sequences usage:
- how many Sequences are we talking about?
- do you also use Sequences Assets ?

Thanks again

1 Like

Hello. I am also using the 2022 LTS and after installing the cinematic studio package set face this error every time i start up Unity get this error. It usually takes 10-20ish minutes for it to stop indexing.

I installed it for the other parts of the cinematic studio package set (cinemachine / timeline) and have no sequences currently.

9915852--1433412--Screenshot 2024-06-29 215439.png