Serialization issue after updating Unity from 2018.2.1 to 2019.2.6

I updated my unity version from 2018.2.1 to 2019.2.6 and now I get an error when trying to save in my game with my serialization. All the code worked fine before I updated Unity and now it doesn’t work. Went through all my serialization and ensured no “ScriptableObjects” even get close to anything with my saving. If I had anything of scriptable objects trying to be serialized like that before updating it wouldn’t have worked then, so not sure why it has errors now.
If anyone has any lead on this, thank you very much because my project is completely busted at this point.

SerializationException: Type ‘UnityEngine.ScriptableObject’ in Assembly ‘UnityEngine.CoreModule, Version=, Culture=neutral, PublicKeyToken=null’ is not marked as serializable.

It’s completely unclear what you actually use for your save system. Based on that error fragment you posted I’ll assume you use .NET serialization (probably the BinaryFormatter ?). If that is the case you clearly have a serialized reference in your object tree that you try to serialize that references a ScriptableObject. The .NET serializer doesn’t come up with fake errors. If it says it got instructed to serialize a type derived from ScriptableObject that you have instructed it to do so. There is no other way this can happen. Since you haven’t provided any relevant information this question is a dead-end…