"Set-up Android SDK path to make Android remote work" 2019.1.1

Hi I have followed the instructions on the unity manual for running my project with unity remote 5 with Unity 2019.1.1. I seem to have followed all of the steps, but when I click play I get this error:137567-capture1.jpg

My understanding is that android SDK, NDK, and JDK are automatically setting being set up as I selected.

anyone have an explanation?

I had the same issue, I needed to manually specify the Android SDK Tools (second checkbox).
My Path is:
E:\Program Files\Unity\2019.1.0f2\Editor\Data\PlaybackEngines\AndroidPlayer\SDK

Once I changed I closed out of the editor, opened Remote Player on phone (While attached to PC) and then opened my project again and it worked.

Also had to alter Files\Unity\2019.1.0f2\Editor\Data\PlaybackEngines/AndroidPlayer\SDK to Files\Unity\2019.1.0f2\Editor\Data\PlaybackEngines\AndroidPlayer\SDK the difference is the / instead of the \ Took 3 days to get this working!

Great, that works, thanks !
Indeed, this was due to the ‘/’ versus ''

I had the same issue which was also resolved by changing the slash in the path.

I was using unity 2019.4.0f1 on windows 10 for reference.

For whatever reason the default one provided by unity was not being resolved properly. Under Preferences → External Tools, I copied the path and replaced all of the ‘/’ characters with '' for each checked box under the Android section. After manually specifying the paths with the proper slashes for windows paths, the remote app was working for me.

Wrong (checked):

Working (unchecked):

So I just managed to fix this (none of the replies worked for me)

By going into Unity Hub - Installs - 3 dots on the unity version - Add Modules - Platforms - Android Build Support – this was installed but when I extended it with the arrow on the side Android SDK & NDK Tools, and also OpenJDK weren’t checked so I installed those too.

By the way after this, in the project under Edit- Preferences - External Tools they were all automatically checked and no yellow signs showed up like before but you might have to manually enable the checkboxes or browse for the modules for yourself.

For me personally even though all of them were grey as in correct I guess, it still said I had to set it when I tried to run the game so I disabled the checkbox, browsed for it and was exactly where it was looking for it with the same exact name but now when I set it myself it said unofficial version but after a save and unity restart it works now.

problem fixed here : Unity 2020 Android Support: Setup, SDK & NDK & JDK & Gradle - YouTube

I cannot thank you enough with your tip, I was going mad all over the internet getting the same explanation over and over again. I came here and followed your tip and believe me when I say that words cannot express ho overjoyed I felt when my phone screen finally showed my game. Again… thank you so much

I managed to make it work by doing the inverser of you guys, I changed all \ to /
Unity automatically flipped to \ again when I build on device and now it has the same path as originally (with \ ) but the default path check box is unchecked… well no idea what happened but worked :stuck_out_tongue:

Thank you very very very very very much~