Shader and Dynamic batching problem

my car model has 290 verts and 210 tris . When i use Diffuse shader dynamic batching is happening but when i use legacy/lightmapped/bumped diffuse , dynamic batching is not happening . As mentioned in official doc . 300 or less verts that i require for dynamic batching . So, what’s going wrong ??

Did you see this page on Dynamic Batching?

Study all the points under the “Tips” section and make sure the shader you want to use obeys all of them. For example, something which is bumpmapped will certainly need more data than just Vertex Position, Normal and single UV. It also needs tangent, for instance. In that case, the max vertex count drops to 180 and then your mesh violates the limit.

There is also a note about lightmapped shaders:

Objects with lightmaps have additional renderer parameter: lightmap index and offset/scale into the lightmap. So generally dynamic lightmapped objects should point to exactly the same lightmap location to be batched.

Does your setup obey this requirement?