Shader Graph not updating time related nodes in preview

Hey! Been fiddling around with shader graph for a bit and its a blast, but I can’t figure out how to make the preview update when time is involved. If I click play everything is great, but I can’t see the shader animate in the preview part of the shader graph.

Yes, i think this is HDRP problem. There is one thing you can do, that is click on the icon button on the scene view and tick “Animated Material”. If your animated material works correctly, you should still be able to see the effect which should have been instead in “Main Preview” in Shader tab. This is just a wok-around that I find useful.

For me it was fixed by ticking the ‘Always Refresh’ checkbox under the icon for “Toggle skybox, fog, and various other effects.” The icon looks like two stacked planes with a star in the upper right hand side.

I have the same issue. This seems to be related to the HD Renderer Pipeline.
I tried swapping to the Lightweight one, and it works again. Hope this gets fixed.

dock the window

I have exactly the same issue with 2019.4 LTS and the actual 2020.1

EDIT: Uh … ok, it worked by enabling Animated Material on the “Toggle skybox, fog and various other effects” icon in scene view.

I don’t know if I had the same issue but in my case the Shader Graph preview showed what I expected but in game nothing happened.

I solved my issue (or at least got around it) by creating a Vector1 variable in my shader graph and setting it to be NOT exposed (this makes it “global”) and creating a small C# script that controls it something like this:

    void Update()
    {
        t = Mathf.Sin(Time.time);
        Shader.SetGlobalFloat("_sTime", t);
    }

I am using HDRP on 2020.1.14f1