Shader white on Quest 2 when reflection intensity > 0

I’m having problem with a shader that becomes white with a few black spots in it when uploading it to Quest 2 but works fine in Unity. I tried minimizing unknown factors by exporting it to a new URP project containing only this crystal, its shaders and textures as well as the XR Plugin required to build and run to quest 2. This shader has a reflection intensity value that makes it shiny in Unity but if it is anything above 0 it will just be white on Q2.

I would really like to understand why and if there is any way of getting this to work on Quest 2. I just don’t have enough knowledge to know where to look or what to try to solve this

A minimal reproducable project can be found here if anyone would be interested in seeing more details crystal scene.zip - Google Drive.

If seeing the shader code helps you understand it, you can take a look at it here.

Screenshot from Q2

Screenshot from Unity

Strategies we’ve tried:

  • .apk with a fresh scene containing only the crystals
  • .apk with decreased emission levels on crystal shaders
  • .apk with … Settings > Quality > Check “Texture Streaming”
  • .apk with reflection probe
  • .apk with Settings > UniversalRP-MediumQuality > Depth Texture Checked
  • .apk with Building Settings: Texture Compression: ASTC

The only thing that has made a difference is setting the Reflection Intensity value for the Shader to 0, though the result is not nearly as visually appealing as the original: