Shadow Casting Distance

How do you change the distance at which shadows cast on objects?

Right now I have a helicopter, which is actual scale in centimeters, that the rotor doesn’t cast a shadow on the body of the helicopter until about halfway down the nose. Another example is the outside of the aircraft not casting a shadow on the floor of the inside, instead I get the rotor shadow. It seems the distance between the objects is the issue since raising the rotor up makes the shadow climb up the helicopter until it completely appears after the rotor is floating above the body.

Any ideas?

Perhaps you could try adjusting the quality sitting of your lighting.

Edit>Project Settings>Quality

From there you can adjust the “Shadow Distance” among other things. There are a bunch of other settings there you could fiddle around with. Perhaps there may be something there.

Edit the shadow distance at the quality settings. Be careful though as very high values tend to make shadows look less detailed.

You can alternatively scale everything down , including the world , so that the distance between rendered objects is smaller.

There is a “shadow bias” setting on the light. You might trying adjust that. But most likely the problem is your world scale. You say your helicopter is actual scale in centimeters. Is it a R/C model helicopter? If your objects are all just fractions of a “unit” in size, then this could affect shadow and possibly collision detection and other things. Unity is not entirely scale independent and you should attempt to have your objects be multiples of a “unit” and not just tiny fractions of it.

Seeing that both of the previous solutions didnt solve the problem , you should check if your model normals are imported improperly.

In your helicopter’s import settings you can try setting the normals to “Calculate” and see if this fixes the problem.