Shadows are buged for me...

Well…

When i tried to add shadows to my Game everything was fine at first, in the editor i could even hit play and had shadows everything like it should be, but when i build my game and start its exe there are no shadows and the terrain isnt there… Also my directional light is gone the objects that are there turn black(no light), but i can move and everything the terrains collider work fine. it’s just that the terrain is invisble (but it’s there) and the light is gone and of course no shadows at all(no light = no shadows)…

also i have to say the following:

  • when i save my scene with the directional light turned cast shadows
    on and restart unity it crashes when
    it loads the scene.
  • it happens with every scene that has any shadows enabled.

does anybody know how to fix this or what could be causing this ?

what i tried to fix this

  1. restart unity

  2. restart my computer

  3. leave it for a day

  4. reinstall unity to the newest version

  5. restart computer again…

  6. create a new project with just Terrain, directional light, cube,
    main camera everything set to
    default except for the directional
    light of course i had to turn on the
    shadows for it.

  7. check if it works with hard shadows or soft shadows ← both cause the
    problem

  8. search on the internet for hours if somebody had the same issue…
    nothing

  9. download a terrain which he said works(but for me it also only works
    in editor mode)

  10. check if it makes a difference if im using window mode or fullscreen
    both the same…

  11. update my graphic cards driver.

nothing of the above helped

im using:

  • Acer Aspire V5-573G
  • Windows 8.1 64bit (6.3,Build 9600)
  • Bios version V2.22
  • CPU Intel i7-4500U(1,8Ghz-3,0Ghz ,
    Cache: L1 128KB,L2 512 KB,L3 4096 KB)
  • 8gb ram CPU
  • integrad GPU : HD Graphics 4400 (200
  • 1100 MHz) dedicated GPU : Nvidia GT 750M

also i am using nvdia optimus which switches to the dedicated GPU if im running something in fullscreen but the problem occurs in both window and full screen mode.

another update… Unity seems to have issues with the intel HD integrated GPU series… if you enable shadows the game will be displayed pretty awkward! but with any other gpu it seems to work fine at least for my gt 750m