Shadows disappear after switching platform to Android

Here are the steps to replicate the issue I’m experiencing:

  1. Create a new project
  2. Add a plane
  3. Add a cube
  4. Add a directional light and enable shadows
  5. Shadows work fine at this point (they are displayed in the scene view)
  6. Go to “File” → “Build settings”, click on Android and then Switch Platform
  7. At this point the shadows disappear from scene view, although if I build the project and run it on an android device shadows work.

Switching platform back to Windows works on this project, although it doesn’t (shadows do not appear) on another project.

Why do shadows disappear when switching platform to android?

Thank you

I think I had the exact same problem as you. None of the above solutions applied to me, but tonight I finally found the solution by accident.

Check in Edit > Graphics Emulation. If OpenGL ES 2.0 is selected, you won’t see any shadows. Just change that setting back to No Emulation, and you’ll have shadows again.

Your issue is very common, yet very easy to fix. Change the graphical settings for Mobile (in this case Android) devices.

30569-ex2.png

Edit>Project Settings>Quality>Quality Setings

Click the downward arrow under “Default” to change the default settings. Its defaulted to Medium. Or you can keep it at medium, and change the shadow settings within that.

Regards
Nick