Shadows have weird seams and gaps

Here is the problem:
alt text

I have scoured many posts facing similar issues with shadows

The two answers I have found are that the normal bias must be set to zero or use double sided shadows. Both answers aren’t desirable.

Solution A - Setting Normal Bias to 0:
alt text
As we can see the problem is fixed, but when looking closely another arises

alt text
alt text
When setting the normal bias to 0 all faces seem to have a weird lines, that look similiar to a crt effect.
Although its minor, this surely cant be the compromise to live with in order to use a low poly art style.

Solution B – Two Sided Shading
alt text
Right, everything looks great here, no weird crt effect on surfaces and the shadows look crisp and intact.
However in reality this is only a hack that essentially doubles the amount of faces the gpu has to render.
Now the inside of meshes also get rendered, while it can be ignored since most hardware is usually able to run low poly games, it is definitely not a good solution. Especially in larger games with this art style this could essentially halve the performance.

alt text

So what I’m basically asking for is a solution that doesn’t cause weird artefacts and a performance hit.
Thank you for taking the time to read this post.

Try setting Bias to “Custom” instead of “Use pipeline settings” and set…

“Depth” around 2.61
“Normal” to 0.

That was a solution for me. I hope it works for your case.