Shadows not showing

If im using RayTracing the shadows for trees do not show, but if I turn it off the shadows work good
The First photo has raytracing turned off8700114--1174416--Screenshot_20230102_093107.jpg In the second one its turned on 8700114--1174419--Screenshot_20230102_093044.jpg 8700114--1174416--Screenshot_20230102_093107.jpg 8700114--1174419--Screenshot_20230102_093044.jpg

Can you share the shadow settings?


inside the hdrp assets?

[quote=“ytryrtyrty”, post:3, topic: 904844]
inside the hdrp assets?
[/quote]
Yes

8700294--1174455--Screenshot_20230102_112044.png 8700294--1174458--Screenshot_20230102_112104.png

first one is for high fidelity and second one is for performant
i have the same issue on balanced as in high

Raytraced shadows do not work for objects with static batching enabled.
They also don't work for terrain details & trees. You have to place objects normally, not through the terrain.

The latter goes for all raytracing effects, not just shadows. In a recent version (not sure, maybe 2022.2) terrain can receive raytraced effects like AO, but not the objects rendered through the terrain. (Terrain details & trees won't work still)

1 Like