Shadows problem on mobile


I have a problem that I couldn’t solve by myself. When I run the game on pc I see nice hard shadows from cubes used as terrain, but when I put it on mobile (galaxy note 2) the shadows are in bad quality. Shadows made by other objects are hard and sharp on terrain cubes (seems like casting shadow by ‘terrain’ cubes on it’s self does not work?) I have tried different shaders on terrain cubes materials, different android textures compresion (and quality is set to fantastic) but I still have this not sharp and hard shadow.

What can be the cause? below you can see the printscreen from mobile.


@obses Go to Edit > Project Settings > Quality and

(1) click ‘Add Quality Level’. Then select it in the list of presets and

(2) rename it to something like “MyQualitySettings”. Next, make sure

(3) set your shadow settings correctly, and

(4) click the arrow below the Android (I assume you are using Android if I’m right that a Galaxy is Android) column and enable “MyQualitySettings” (the green checkbox in the Android column should change to your setting).


Let me know if this helps :smiley: