[Shuriken] How to avoid clipping?

Hi, I’m using particle system to emit cube shaped meshes. Problem is that the cube graphics is clipped on collision with the surface. How can I avoid that?

Cube clipped by the floor

Particles use a simplified system for collision detection. Only the particle’s origin is considered. As far as I know, there’s no way to change this behavior. If this clipping issue is a deal-breaker, you’ll need to spawn rigidbody cubes instead of using particles.

You could disable depth testing on their material. The trouble is this could make them get render over the top of things you don’t intend.