SIGILL with Unity 2017.4.17 and command line on headless MacOS

I am having issues building an app using command line on a MacOS Continuous Integration server via Bitrise. It works great with 2017.3.0f3, but we are trying to upgrade to 2017.4.17.

Building an empty project works, but our current project fails by throwing System.ExecutionEngineException: SIGILL:

...
Updating /Applications/Unity/Unity.app/Contents/UnityExtensions/Unity/UnityGoogleAudioSpatializer/Runtime/UnityEngine.GoogleAudioSpatializer.dll - GUID: e4f4cf1b9b434137a499903a7a1d651a...
 done. [Time: 50.694827 ms] 
Updating /Applications/Unity/Unity.app/Contents/UnityExtensions/Unity/UnityGoogleAudioSpatializer/RuntimeEditor/UnityEngine.GoogleAudioSpatializer.dll - GUID: ead147da21254ff9a0a936bdd75e1680...
 done. [Time: 38.557852 ms] 
Updating /Applications/Unity/Unity.app/Contents/UnityExtensions/Unity/UnitySpatialTracking/Runtime/UnityEngine.SpatialTracking.dll - GUID: ed7343f30e3843b3afda8f8b02669cea...
 done. [Time: 8.273156 ms] 
Updating Packages/com.unity.purchasing/Editor/UnityEditor.Purchasing.dll - GUID: f1045c695c5bf4fb7b8509687bc60fc0...
 done. [Time: 5.145811 ms] 
Updating /Applications/Unity/Unity.app/Contents/UnityExtensions/Unity/GUISystem/UnityEngine.UI.dll - GUID: f5f67c52d1564df4a8936ccd202a3bd8...
 done. [Time: 79.930216 ms] 
Updating /Applications/Unity/Unity.app/Contents/UnityExtensions/Unity/GUISystem/Standalone/UnityEngine.UI.dll - GUID: f70555f144d8491a825f0804e09c671c...
 done. [Time: 80.866184 ms] 
Updating /Applications/Unity/Unity.app/Contents/UnityExtensions/Unity/UnityHoloLens/Runtime/UnityEngine.HoloLens.dll - GUID: f7b54ff4a43d4fcf81b4538b678e0bcc...
 done. [Time: 24.041720 ms] 
Reloading assemblies after forced synchronous recompile.
Begin MonoManager ReloadAssembly
Initializing Unity.PackageManager (PackageManager) v2017.4.17 for Unity v2017.4.17f1
Registering platform support modules:
Registered platform support modules in: 0.162269s.
Native extension for OSXStandalone target not found
Native extension for Android target not found
Refreshing native plugins compatible for Editor in 20.91 ms, found 9 plugins.
Unhandled Exception: System.ExecutionEngineException: SIGILL

Simplest Command line argument. Execute method or platform flag does not matter, it never reaches that point. This is geared towards GearVR:

/Applications/Unity/Unity.app/Contents/MacOS/Unity -batchmode -logFile -projectPath /Users/vagrant/git/REDACTED

-nographics or any other arguments do not change the result. Also tried -noUpm as I am not using it

Is there a good way to extract the crash logs or a way to one by one find out what plugin could be crashing the editor if any? What should my next steps be to troubleshooting this problem?

I tested on a Mac locally using the command line, and it worked fine.

For this case, I found the solution.

Oculus Spatializer DLLs via Oculus Integration were crashing the Unity Editor on Bitrise VMs, most likely due to older CPUs