Silent Android build failure

I'm trying to build an Android version of my project. Unity appears to go through the motions, but at the end there is output directory and nothing happens. Nothing is reported to the console. Any ideas? The iOS version works fine.

Ok I figured it out. At least in 3.5. Just restart Unity. iF you switch from any other platform to Android and then try to build, it will silently fail and not generate an APK. I closed Unity, opened it back up, and it built.

I've seen this, I don't know why it does it, but to get around it, I build the APK (Build rather than Build and Run), and 'manually' transfer and install it. It seems to depend on the device. My Droid, HTC, and first Xoom all no problems at all. We got a second Xoom, and it has this problem. I thought it might be the USB port on the Xoom. Are you using a Mac? I'm told there is some 3rd party app you need to get the USB to talk to Xoom, maybe it's related to this problem. Anyway, I'd like Unity Tech to see this and recommend a fix or if it's a bug, fix it.


I am facing similar problem.. I have built up apk file and after i manually install it to xoom device, it opens to the splash screen and got stuck at this screen.

It does not load to the game.. Do u know why ?

Using unity 3.3 Pro..

I’m having this exact same issue. Have not been able to fix it.

I just met this issue in these two days (2/24/2012)
It was fine (Unity 3.4.2 Android and HTC Desire Z)
But after I upgraded to Unity 3.5, I can not build to the same device with any projects anymore.
I thought it was because the something wrong with the Unity version.
After did lots of tests and compared, they all didn’t work.
Turns out, I tried to hit “Build and Run” instead of “Build”, then it works.
All I want to say is , wtf.

i solved that issue enabling red warnings in console window. what a noob i am.

This worked for me , hope this helps :