Skybox hides the planet. Shader issue?

I made a simple scene where you rotate around a planet, I also want to add a skybox but when I add the skybox it will hide the sphere…
What is going on?

p.s: I used the strumpy shader editor for the planet shader and Clamp’s tutorial.
I think it has to do something with the renderqeue settings in the shader, can that be the problem?

Define ‘add the skybox’

You can set the textures in the Edit/Render Settings, and/or on the camera. I hope you didn’t just make a big box and add textures to it and put it in the scene (without having a separated camera for it)