Skybox Pixelation problem

Skybox seems to e pixelated. If the camera FOV is 60 it seems to be perfect. When I change the FOV to 30, there is a pixelation. Also, I have tried all the render settings and nothing worked. Is there any way to set my FOV to 30 and get a good resolution skybox? In Scene view port it looks perfect.

Any help would be highly appreciated. Thanks.

Any updates on the solution to this issue?

Change compression type of skybox textures to None. I had bad quality despite compression type being “HIgh quality”

Did you set the texture resolution for a higher resolution?

Edit> Project Settings> Quality > Anti Aliasing set as 8x Multi Sampling… it will be clear

Change compression type of skybox textures.

I’m guessing you zoomed too much in and it showed the resolution. Though my skybox is using 512*512 images and it doesn’t get pixelized, so it could be the filtering option of your images. Set it to bilinear if it’s point sampling.

I think I found a workaround to the problem (I tested all the previous replies, unfortunately none worked for me for the same case.)

Basically, you need to create two cameras (Main Camera > Skybox Camera, which the latter is child of Main Camera).

Main Camera Settings:

-Clear Flags: Depth Only

-Culling Mask: Everything (Or based on your preference)

-Field of View: 30

-Depth: 0

Skybox Camera Settings:

-Clear Flags: Skybox

-Culling Mask: Nothing

-Field of View: 62 (My preference)

-Depth: -1

(And for performance concerns, I set Rendering Path to Legacy Vertex lit as there won’t be expensive lighting calculations except simple skybox, also HDR and MSAA are set to OFF too, Target Eye: None).

This workaround has around 8% performance impact on FPS. I get 110 FPS with this on and (135 FPS off) and it is okay for me.

Credit for this workaround goes to WillBellJr: