.sln file in latest version of Unity3D 2018

Good day,
I am trying to edit my PlayerAnimManager c# file but I get a message that no .sln can be found.
I’ve read through other answers and included the VS 2017 Tools for Unity in my assets.
I’ve seen suggestions to go to the menu and use an option to create the .sln but I cannot find the Visual Studio Tools anywhere on the Menu Bar or inside any.
I have tried reimporting my C# scripts and that does not create the .sln.
At this time I’m at a bit of a loss how to proceed. If anyone could help, it would be greatly appreciated.
I tried every message that came up with a search for sln before I posted this question.
Regards,
Nat

Have you set your external script editor as visual studio by default in unity preference?

Your answer put me on the right path; thank you so very much!
I remembered that I just received a Windows 10 update and as happens on occasion it apparently reset the permissions for Microsoft VS 2017. I reinstalled Microsoft VS 2017, started up Unity and it asked me to allow access to VS. Once I did that my C# functionality is working perfectly! The .sln file has been created and all is well in my universe.

Regards!
Nat

My solution was simple:

Open Unity preferences → go to “External Tools” → make sure “External Script Editor” is set to “Visual Studio 2019…” or “Visual Studio Code” and enabled and check the Checkmark “Generate all .csproj files”.

After setting it up the field “External Script Editor Args” should be updated automatically to something like "$(ProjectPath)" -g "$(File)":$(Line):$(Column)

After this the sln and csproj files are generated.

First I tried to re-install Visual Studio again and re-import all assets in Unity, but this was very time consuming and did not solve the issue.