Small objects won't emit light, large ones will. Testing with sphere.

Emission on this simple sphere will not work unless the sphere is large. Is this normal? This is obviously a problem that is making my life difficult with all of the models I have created. I can’t get a light bulb to use emission unless I crank up the size of the model in my scene.

I have looked but can’t find any information on how big a model should be before emission works. Is this maybe a problem with my Lighting “Scene” settings that I can’t figure out?

FYI All objects set to static, when I change the size of the sphere and bake the lighting I get the results in the image.

Any help is appreciated.

Answered my own question. I’ll post this in case anyone else has this issue.

In Maya, I do create my model in cm or meters. On FBX export, I left it as Automatic. This brings it into Unity as a 0.01 file scale. Not good. Instead, I take it off automatic and switch it to Meters. This brings the models in at a 1:1 scale.

All good!

Has this been answered in another thread. I have same issue