[SOLVED] Advertisments Legacy NO_FILL - Placement recieved no fill

Banner Ads and Rewarded Ads suddenly started not working in android build. So far the ads are in test mode so, not finding a fill for the ads seems bizarre. The ads seem to work in the editor as well. Checking the android logcat, Ads service are initialized yet the ads are not loaded. It used to work yesterday but suddenly started not working today for no apparent reason. Below is the log for the error:

2023/11/14 19:02:15.305 Info Unity Unity Ads initialization complete.
2023/11/14 19:02:38.533 Info Unity Loading Ad: Rewarded_Android
2023/11/14 19:02:38.832 Info Unity Error loading Ad Unit Rewarded_Android: NO_FILL - Placement receives no fill

For some reason banner ads doesn’t even raise an error log. Advertisements Legacy version is 4.4.2.

UPDATE: It fixed itself this morning. It started working in the same build.

Some for me, editor works fine, on device NO FILL…
Bug - Ads on test mode not showing on device - Unity Forum

Same here, doesn’t work for me. Editor shows test ads. When I run on device with testMode as false. I get a No Fill error.

Please note that ads may not be filled every time, it depends on region, campaign availability, and the advertising market price, which can fluctuate over time. If the ad fails to load, please try reloading the ad after a while.