[SOLVED] Animation clip not playing in "complex" Timeline project

Hi everyone,

I'm currently working on an animation film done with Unity and I've found that my animation clip doesn't play when it's in the shot timeline. But will play when it's in the sequence timeline or a timeline children of the shot one.
The animation will play in "Play Mode" but will not be visible in scene view. But if I then scroll through the timeline, the animation won't play anymore.

I manage to recreate the issue in a default project, the Unity version for both projects where I have the issue is 2019.4f1 with HDRP 5.7.2

The following screens shows the timeline configurations where the animation clip is playing both in scene and game view.

4616491--432022--upload_2019-6-5_17-8-42.png

4616491--432025--upload_2019-6-5_17-13-24.png
but then the GameObject of the Timeline is disabled..

So it is good to know that the scene hierarchy is as follow:
4616491--432037--upload_2019-6-5_17-16-50.png

Now here is what we'd like to work with but it doesn't work:

4616491--432031--upload_2019-6-5_17-15-27.png

And for some unknown reason it doesn't play the animation clip with this kind of structure.

a weird behavior occurs when I move the clip, it will sometimes start the animation but the clip will be offset like here. Then I first thought that I just had to change the value of the "Start" in the Clip Timing but the result is the same as below:
4616491--432040--upload_2019-6-5_17-22-2.png

Finally, when I go into the first shot timeline, I will see the cube playing the animation!!

Should I report a bug ticket or is there actually something that I'm doing wrong? It sounds definitely like an issue but I want to be sure

When the cubeAnim does not work in the 0030 timeline, is it being animated in any other shot? It sounds like there is fighting going on over which sub-timeline is actually animating it. Moving the clip causing it to animate seems to indicate that.

Even if the clip is in the grey-ed out area, the extrapolation will still be applied. (The small infinity sign indicates that).

When I go into the first shot, 0010, the cube is playing but there's no clip in that timeline so I don't understand why it plays it it there4616605--432058--upload_2019-6-5_17-54-45.png

I suspect it's in RE01_MasterTimeline, or another sub-timeline of that is active at the same time. When scrubbing/playing in a subtimeline, it's actually playing the master.

So now we've tried something else and it seems like its a Windows issue. We had a Film Sample project on Mac, upgraded it to 2019.1.5, everything was playing as expected. Then we opened the exact same project on Windows and the issue occurred again. The animation doesn't start where it should. For some reasons we must change the Clip Timing Start to the value of the time it is supposed to play in the sequence timeline.
So if the 3rd shot begins at 10s. I must change the Start value to 10 to actually see the animation

keep you posted on what we'll found more

Also, the bug happens only when the RE01 timeline is active.
4619287--432472--upload_2019-6-6_12-30-41.png
but this does work
4619287--432466--upload_2019-6-6_12-30-5.png

4619398--432481--upload_2019-6-6_12-57-37.png

Alright it seems that the Control Children on the sequence clip in the MasterTimeline was causing the problem. Once I disabled it all the clips were playing fine

8280645--1085196--upload_2022-7-15_12-19-55.png
What i am supposed to do? i dont understand why this errors happened

built in unity bug