[SOLVED] Animation Clip Properties not saving with Apply

A bug has randomly appeared where I am unable to apply any changes to an animation clip. This includes adding animation events, checking Loop, changing any settings, etc. When I hit apply, it acts like the changes are being saved but then immediately reverts back.

What is interesting is that the Apply/Revert buttons stay active (not grayed out) and if I click away from the clip Unity asks if I want to apply/revert the changes. So changes are being detected, but not saving.

I say randomly appeared because I have been using 2019.3.12f1 for sometime and was able to add events/make changes before just fine. This only started happening when I accidentally tried to add an animation event to a clip while the game was running. Now anytime I make adjustments to any clips, they all get reset.

I have since updated to 2019.4.1f1 and the bug still happens. I've tried deleting and re-importing the clips with no luck.

1 Like

As I wrote this an idea came to me and I revisited the whole Apply/Revert buttons staying active. I can confirm this is a bug and will open a ticket accordingly, but in case anyone else comes across this here is a workaround.

Here is the full workflow

  • Make any type of change to the animation clip you want (Add an event, check looping, etc.)
  • Hit Apply
  • The inspector will revert all the changes, but you will notice that the Apply and Revert buttons are both active (not grayed out).
  • Hit Revert
  • Your changes will show back up, are saved, and the Apply/Revert buttons are now inactive (grayed out)

Adding a video showing the issue.

Edit: Also if you have multiple clips on the same FBX and you make multiple edits at one time, you'll have to keep hitting the revert button multiple times until it is grayed out for all the changes to appear.

1 Like

Well I spoke too soon, while the inspector does show that the changes are there and saved, when playing in game and when inspecting the clips directly the changes are not saved. This means I have events shown in the inspector, but they are not firing during play.

Also loop animations will show as Loop = true when inspecting the FBX, but inspecting the clip directly shows Loop = false and they do not in fact loop during play mode.

So i'm at a loss again here. Anyone else experiencing this?

Bumping this. Had submitted a bug, but the case was closed since it's not something that can be reproduced in a new project. Is there any solution to this bug for existing projects?

1 Like

I had the same problem. Turned out one of the scripts (Character Creator3 model importer) was blocking the fbx properties from being changed. But once I removed the script everything went back to normal.

1 Like

Well i'll be. I had actually tested CharacterCreator3 awhile go and simply imported one model and then never used it again. I forgot I had it in the project. I just removed the editor file it provides and sure enough that fixed the issue.

So thank you!

1 Like

@Yakuzza and @Thoranar

Thank you!!!! This also fixed the apply / update issues I was having with an animation clip length.

I dont have Character Creator but are having the issue of not being able to apply changes in unity 2020.2.1f1

1 Like

Bump....For CharacterCreator3, I think it's the auto-processing option. If the fbx was in CC_Assets, the plugin detects changes to the import settings and reverts them back to what it thinks is ok. But I'm thinking it might be registering files anyhow, like beyond what is still in CC_Assets, because I've seen such issues even after I relocated the animation fbx and avatar fbx files outside CC_Assets. And it seems to be influencing all fbx files that have been in that folder because I have this mixamo standard walk animation which I initially put next to the avatar fbx(inside CC_Assets) then I disabled auto-processing(I expect the plugin is loaded anyhow on editor launch) and after moving them out, I still have issues with just the Animation tab.I can change the rig or other options, but I can't change the animation clips. I check Loop and hit apply, it shows as if it reverted Loop to false, but if I click Revert, the importer settings show Loop checked. Despite that, the inspector for the anim clip shows Loop unchecked. And I get a message to apply unapplied settings even if I have applied them once.

UPDATE: deleting the CC3 dll fixed it. This is yet again an issue. Native dlls cannot be unloaded on runtime in the Unity editor. I suspect that unchecking Auto-process, loads the dll but the dll is bugged and does not check Auto-Processing flag.

UPDATE2: It was my fault. The project I was testing in, was older than the last version of Reallusion's Auto-Setup script. I was using the 1.02 version, instead of the 1.1 that I was using in other projects. Release notes for 1.1 mention a fix for the animation changes. Although the forum report does mention that this operates on any fbx and not just fbx that's been exported by CC3.